An API can no longer be enabled after applying CR2

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Article ID: 5221

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Updated On:

Products

CA API Developer Portal CA API Gateway

Issue/Introduction

After applying CR2 to CA API Developer Portal 3.1 an API can no longer be enabled.

You may also lack the ability to create a new API in the Developer Portal.  CA API Developer Portal 

Cause

It was noticed that with the initial release of CR2 the included PDF contained invalid characters in the instructions for editing the properties.xml.

If this section was copied/pasted from the PDF the invalid character () would be added to the properties.xml causing this issue.

 

Problematic XML: 

<Property name=cmsConfig.invalidMimeTypes value=application/x-dosexec,application/xmsdownload,

 

application/x-executable/>

Environment

Release: L7APIP99000-3.1-API Developer Portal-Perpetual
Component:

Resolution

To resolve the issue please follow these instructions:

 

 1. Edit the properties.xml and location this section

<Property name=cmsConfig.invalidMimeTypes value=application/x-dosexec,application/xmsdownload,

 

application/x-executable/>

 

 2. Replace the text with the below:

<Property name="cmsConfig.invalidMimeTypes" value="application/xdosexec,

application/x-msdownload,application/x-executable"/>

 

 3. Rebuild and publish generated content (/admin?action=PLUGINsitebuilderplugin):

        a. Click ‘Regenerate Template Editors’.

        b. Click ‘Regenerate Standard Files’.

        c. Click ‘Publish Standard Files’.

 4. Wait for the event queue to empty (verify on /admin?action=PLUGINrepositoryeventmanager)

 5. Restart the CMS: 

       service apiportal restart