CA NFA DNS/SNMP Proxies will not start on my NFA Harvester.
search cancel

CA NFA DNS/SNMP Proxies will not start on my NFA Harvester.

book

Article ID: 5209

calendar_today

Updated On:

Products

Network Flow Analysis

Issue/Introduction

After installing/upgrading NFA I cannot start the "CA NFA DNS/SNMP Proxies" service.

 

The <Install Dir>\CA\NFA\Netflow\Logs\proxies-wrapper.log file will show an error like:

Error: com.sun.xml.internal.ws.server.ServerRtException: Server Runtime Error: java.net.BindException: Address already in use: bind

 

Environment

NFA All Versions

Cause

NFA uses port 8081 for this service, if another application such as McAfee is also using this port it will prevent the service from starting.

Resolution

You can change the port number that this service uses on each Harvester server to a port that is available such as 8089 by following the respective steps:

1. Open a command prompt on the Harvester and type:

mysql harvester -unetqos -pnetqos

2. Then update the port number (e.g. to port 8089) by running:

Update settings set value = '8089' where name='SnmpProxyPort';

3.  Attempt to start the service again and it should start.

4.  On the NFA Console Server, edit the C:\CA\NFA\REPORTER\NetQoS.ReporterAnalyzer.ManagerService\bin\ReporterManagerService.exe.config file from:

  <!-- New Java DNS Proxy webservice--> <add key="DnsProxyClient.JavaDnsProxyUrl" value="http://{0}:8081/dns"/>

to 

  <!-- New Java DNS Proxy webservice--> <add key="DnsProxyClient.JavaDnsProxyUrl" value="http://{0}:8089/dns"/>

5. Save the file and restart the NetQoS Reporter Manager Service on the NFA Console.

Additional Information

If setting the port to 8089 does not allow the service to start, please verify that this port is not also in use and pick another available port for this service to run on.