Unable to complete pdm_configure when using Oracle database

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Article ID: 5193

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When completing a configuration of Service Desk Manager to an Oracle database the configuration fails to connect to the database. Within the configure.log file an error is logged "Unable to load the OCI library or DLL. Cannot continue!"

Cause

This error is typically seen if a 64bit Oracle client is installed on the Service Desk Manager server. Service Desk Manager requires the 32bit Oracle libraries in order to establish connection to the Oracle database.

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License
Component:

Resolution

1)

Install the 32-bit Oracle Client software to a separate oracle base location

-do NOT install the "Instaclient" - but rather use the "Administrator" option

2)

For Windows:

Include the path to the 32bit Oracle library (lib) directory in the windows PATH

For Linux:

After the client install completes point the LD_LIBRARY_PATH to the client's "lib" directory and the CA Service Desk Manager "lib" directory for the root user

Example: edit /etc/profile and set the LD_LIBRARY_PATH as follows 
LD_LIBRARY_PATH=/opt/oracle/product/11.2.0/client/lib:/opt/CAisd/lib

NOTE: If you are adding the “$LD_LIBRARY_PATH”, append it to the end of the export line. The client lib needs to come before any other oracle lib directory references as programs will go with whatever they find first.

3)

Re-Run pdm_configure, which should now proceed.