Reinstallation of a Distribution Server

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Article ID: 5187

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Updated On:

Products

CA Privileged Access Manager - Server Control (PAMSC) CA Privileged Identity Management Endpoint (PIM)

Issue/Introduction

By mistake we installed the Distribution Server giving a wrong communication password.

We are facing in the Message Queue EMS.log
...
2016-12-06 12:05:15.215 Unable to initialize route 'EMS2POM': route server returned: 'invalid name or password'
...

We try to completely uninstall the Distribution Server and then reinstall the Distribution Server from scratch with the correct values.

Still we see the reinstalled Distribution Server not communicating with the ENTM Server.

Cause

While installing the Distribution Server it is registering with the ENTM Server using the values given in the installation wizard.

These registration records on the ENTM Server are not removed automatically upon uninstallation of the DS.

 

Environment

Release: ACP1M005900-12.9-Privileged Identity Manager
Component:

Resolution

Before reinstallation of the Distribution Server remove any references of this host from the Message Queue configuration files, i.e.

1. on the ENTM Server please remove any references to the problematic Distribution Server from these files in ../tibco/cfgmgmt/ems/data
  groups.conf
  users.conf
  routes.conf

2. restart the CA Message Q service on the ENTM Server

3. on the problematic Distribution Server remove via Windows Control Panel / Programs & Features the CA ControlMinder Distribution Server component

4. mount the CA ControlMinder 12.8 Enterprise Server ISO/DVD on this box and install via the Product Explorer the CA ControlMinder Distribution Server afresh

5. confirm on the ENTM Server that relevant references were put in the files
  groups.conf
  users.conf
  routes.conf
   to the reinstalled Distribution Server