Jobcheck on agent returns "number of client connections to the server exceeded"
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Article ID: 5132
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Updated On:
Products
CA Automation Suite for Data Centers - Configuration AutomationCA Client Automation - Asset ManagementCA Client Automation - IT Client ManagerCA Client AutomationCA Client Automation - Remote ControlCA Client Automation - Asset IntelligenceCA Client Automation - Desktop Migration ManagerCA Client Automation - Patch Manager
Issue/Introduction
The following error occurs while running jobcheck on an agent: "The number of client connections to the server exceeded".
Cause
The Scalability server limits the number of simultaneously executing agents to ensure the performance of the scalability server is not impaired.
If the SS is already deploying a large deployment and you then try to deploy to a single PC it is probable that the PC will not be able to connect to the SS immediatley.
If you attempt to manually jobcheck at this point you will see the error
This is controlled by the policy "Concurrency: Maximum number of simultaneously executing agents on Scalability Server" which can be found under:
Control Panel->Configuration->Configuration policy->Default Computer Policy->DSM->Software Delivery->Scalability Server.
Increasing the value of this policy will allow more agents to connect at once.
You can also wait for the SS to become less busy and the job will go through
Additional Information
NOTE: There could be performance issues if this number is increased since this relies on the hardware configuration of the server and the network bandwidth available.