Error "Exception in thread "Main Thread" java.lang.UnsupportedClassVersionError: com/wily/field/dpmon/DataPowerMonitor : unsupported classversion 51.0"

book

Article ID: 5131

calendar_today

Updated On:

Products

APP PERF MANAGEMENT CA Application Performance Management Agent (APM / Wily / Introscope) CUSTOMER EXPERIENCE MANAGER INTROSCOPE

Issue/Introduction

Starting the Datapower Extension is not successful and results in this error:

[[email protected] /webapps/wily/DataPower3.2/bin]$ ./DatapowerMonitor
Exception in thread "Main Thread" java.lang.UnsupportedClassVersionError: com/wily/field/dpmon/DataPowerMonitor : unsupported classversion 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Could not find the main class: com.wily.field.dpmon.DataPowerMonitor. Program will exit.

Cause

 The customer was running JVM 1.6. However, the Datapower 3.2 Version needs to be run on JVM 1.7 or higher.

Environment

This was during testing in a 10.2 APM Environment

Resolution

Upgrade the JVM to be release 1.7 or higher

Additional Information

Download the Datapower Extension 3.2