CA Automation Suite for Data Centers - Configuration AutomationCA Client Automation - Asset ManagementCA Client Automation - IT Client ManagerCA Client AutomationCA Client Automation - Remote ControlCA Client Automation - Asset IntelligenceCA Client Automation - Desktop Migration ManagerCA Client Automation - Patch ManagerCA IT Asset ManagerCA Software Asset Manager (CA SAM)ASSET PORTFOLIO MGMT- SERVERCA Server AutomationCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
Description:
Problem
DSM Explorer will not open
Running %program files%\ca\dsm\sc\egc30n.exe results in the following popup
<Please see attached file for image>
Clicking OK then displays
<Please see attached file for image>
Environment
Windows Server 2008 SP2 (Enterprise Edition, Standard Edition, Datacenter Edition) 32- and 64-bit
Windows Server 2008 R2 (Enterprise Edition, Standard Edition, Web Edition, Datacenter Edition) 64-bit
Windows Server 2003 R2 SP2 (Enterprise, Standard) 32- and 64-bit
Windows Server 2003 SP2 (Enterprise, Standard, Web) 32- and 64-bit
Windows 7 XP Mode (Enterprise, Business, Ultimate) 32- and 64-bit
Windows Vista SP2 (Enterprise, Business, Ultimate) 32- and 64-bit
Windows XP Professional SP3 32-bit
Windows XP Professional SP2 32- and 64-bit
Windows 7 (Enterprise, Business, Ultimate) 32- and 64-bit
Windows 7 N (Enterprise, Business, Ultimate) 32- and 64-bit
Solution:
Resolution
Open Windows Explorer and browse to the drive where ITCM is installed
Delete or rename the file x:\program
Cause
The presence of this file prevents the path variable being evaluated correctly and thus the Explorer cannot open. From observation this file is created a scheduled task on the computer in question.