Error: "The system was unable to log you in. Please make sure the provided credentials are right."

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Article ID: 5093

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

The following error appears when testing the connection from Unified Self-Service to Service Desk Manager datasource:

The system was unable to log you in. Please make sure the provided credentials are right.

In addition to the previous error, the following error messages is logged in wrapper-tomcat.log:

javax.xml.ws.soap.SOAPFaultException: Error: invalid login policy encryption
at com.sun.xml.internal.ws.fault.SOAP11Fault.getProtocolException(SOAP11Fault.java:178)
at com.sun.xml.internal.ws.fault.SOAPFaultBuilder.createException(SOAPFaultBuilder.java:125)
at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:108)
at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:78)
at com.sun.xml.internal.ws.client.sei.SEIStub.invoke(SEIStub.java:135)

Cause

The certificate is old and expired. In Service Desk Manager server the pdm_pki has been run to create a new PKI certificate, causing the previous certificate to expire.

Environment

CA Service Management 17.1 and higher

Resolution

Follow the steps below to load the new PKI certificate into Unified Self-Service for Service Desk Manager:

1) Log into an SDM Server where you have the new pki file (CASM_POLICY.p12 file)

2) Open a browser and log into one USS node as casmadmin or similar > Settings > Datasources > Expand CA Service Desk Manager > click on "Upload Certificate" > Search for the CASM_POLICY.p12 file

3) Click on test connection > ensure test connection is successful and click Save.

4) If there are multiple USS nodes, repeat the step 1 to 3 for the other USS nodes.

Example of a successful connection:

Additional Information

How to configure the integration between Service Catalog and CA SDM

How to configure Service Desk and Service Catalog integration so that to open service desk ticket link within a catalog request correctly

SDM: USS auto integration with SDM failed
 
If a new SDM policy file CASM_POLICY.p12 was created on the SDM server, follow below additional steps if the original steps above did not resolve the issue:

  1. Restart SDM
  2. Copy the correct CASM_POLICY.p12 file to USS node
  3. Stop USS
  4. Search for *.p12 in C:\Program Files\CA\Self Service\OSOP
  5. There should be a CASM_POLICY.p12 file here: C:\Program Files\CA\Self Service\OSOP\shared\aquila_temp\10196
  6. Move it over to a backup folder and delete the file
  7. Restart USS
  8. From a browser machine (copy the correct CASM_POLICY.p12 file to the browser machine first), try to configure the SDM data source again now with the correct CASM_POLICY file.

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