Incomplete Software Inventory (Signature Scan). Status of task is OK
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Incomplete Software Inventory (Signature Scan). Status of task is OK

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Article ID: 5091

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Updated On:

Products

CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

The Software inventory (signature scan) is partial. The software inventory collect task is in status OK.

Even after a full Software Inventory scan (with command like caf start amagent args -rescan_software -collect) the inventory is still incomplete.

Environment

Client Automation - All versions.

Cause

This problem could be caused by a wrong Software Definition in the XML file.

A problem or invalid character could be introduced in custom created signature when using the XML field to create the Software Signature.

 

Example :

In this screenshot, some quote characters have been created using ascii code 148 instead the valid ASCII code 34

 

This is causing a parsing error during load of XML file by Software Inventory module.

All signature definitions stored in the xml file after the Software Definition in problem are ignored. This is causing incomplete Software Inventory.

Resolution

The solution is to correct the XML definition of custom Software signature in problem.

In order to find it easily we could use this method :

1- On one agent machine, open a DOS prompt and execute following command :

amswsigscan.exe -D "C:\Program Files\CA\DSM\Agent\units\00000001\uam\W0000569.XML" "%TEMP%\amsoft.xml"

Remarks :

  • Replace C:\Program Files\CA\DSM\Agent\units\00000001\uam by the valid path on the machine.
  • Replace W0000569.XML by the valid XML filename stored on the machine.

 

If there is a problem in xml file an error message like this one appears :

 

XML parse error (not well-formed (invalid token)) on line 1888963

Invalid XML  [FATAL]

 

 

2- Open the XML file with a text editor and go to the mentioned line. The Software definition in problem is found :

 

On Unix/Linux the method is the same. The command line is :

caevmscli -D "/opt/CA/DSM/Agent/AM/data/work/l0000564.xml" "/tmp/amosoft.xml"

Replace /opt/CA/DSM/Agent/AM/data/work/l0000564.xml by the valid path and filename for l0*.xml file

 

 3- Try to find what is the invalid syntax or characters and in ITCM GUI, edit the software definition and correct the syntax of XML definition.