Upgrading the NAC fails with error "Checking for running jobs..Active jobs were found, Please stop all active jobs and continue the upgrade process"

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Article ID: 5078

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio) CA Release Automation - DataManagement Server (Nolio)

Issue/Introduction

Upgrading Release Automation may fail even though all steps as listed in the documentation for upgrading Release Automation.

In dashboard no processes under running state, yet while running the upgrade following error shows up:  "Checking for running jobs..Active jobs were found. Please stop all active jobs and continue the upgrade process"

Cause

Even though the dashboard does not list any running or long running jobs, there may still be jobs within the database that prevent the upgrade from succeeding.

Environment

Can occur during any upgrade between versions.  For example upgrading from  6.4 to 6.6. 

Resolution

1. Login to the JMX Management Console: http://<NAC IP/FQDN>:20203/ (it will prompt for a username and password, both of which are, by default, "nolio"). 

2. From the "Server view" tab, locate the "Domain: noliocenter" category. 

3. Click on "noliocenter:type=ExecutionCaches" option. It will then open MBean "noliocenter:type=ExecutionCaches" under the "Mbean view" tab. 

4. Under the "Operations" category, click the "Invoke" button for the "showJobsCache" option. If there are any current deployments, they will be listed here. Various details about each deployment will show, including the Job ID, which should be noted down. 

5. From the "Server view" tab, return to the "Domain: noliocenter" category. 

6. Select "noliocenter:type=info" to open it under the "Mbean view" tab. 

7. Under the "Operations" category, enter the Job ID in the field for the "Parameters" option for "removeProcessRun". 

* Click the "Invoke" button to kill the process.

Additional Information


Upgrade Best Practices can be found here:
https://knowledge.broadcom.com/external/article/108005

And the following community post contains an Upgrade Check List:
https://community.broadcom.com/communities/community-home/librarydocuments/viewdocument?DocumentKey=6ec12800-0d75-4603-915c-aaf704d59abb