CIC.log shows "Null" value in proxy details and default software content download job failing.

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Article ID: 5054

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Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

Proxy detailed are configured in default configuration policy . Default software content download job on system engine failing and CIC logs shows "Null" value in proxy section as below. 

Proxy - isUsed: true Host: null User: null Password: null 

Cause

Config.xml has Null or wrong proxy details . Configuration policy settings not getting updated in config.xml and ca_cic_manager table shows wrong details due to this. 

Environment

ITCM Domain Manager with CIC installed for running Default software content download job.

Resolution

Please try the below mentioned steps. 

1. Unlink the default software content download job from system engine. 

2. Edit and add proxy details in config.xml (C:\Program Files\CA\SC\CIC\conf)

<content_server_connection_properties>

    <url>contentupdate.ca.com</url>

    <unitId>f6b84e6d-a00d-03e5-9b5b-e34fcf29b80a</unitId>

    <proxyName/>

    <proxyPort/>

    <proxyUser/>

    <proxyPassword></proxyPassword>

save config.xml . 

3. Add Default software content download job to system engine and try running it again. 

4. Check CIC log if Default software content download job is ERROR. If CIC log still showing Null Value for proxy details, Try executing below queries on MDB.

1. Make sure that user login to SQL Studio with Administrator permission. Unlink the Default software content download job from system engine . 

2. Update the mdb table  (ca_cic_manager) with below query

 Use Mdb

update ca_cic_manager set value='10.33.241.200' ( Add your poxy ip here)
where name = 'cic.contentServer.proxyName'

update ca_cic_manager set value='x02c841c+XxTWgk0olAxTw=='( copy the encrypted password from config.xml and paste it here)
where name = 'cic.contentServer.proxyPassword'

update ca_cic_manager set value=8080 ( add proxy port which you are using).
where name = 'cic.contentServer.proxyPort'

update ca_cic_manager set value='user1'( Add proxy user here)
where name = 'cic.contentServer.proxyUser'

3. Add default software content download job to system engine again. Run the job again and waif for the status. 

 

Additional Information

Note: If still job failed with ERROR . Open a support ticket with ca by attaching the cic.log's .