pdm_configure changes the Attachments repository path settings.
search cancel

pdm_configure changes the Attachments repository path settings.

book

Article ID: 5047

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When pdm_configure is run, the Upload Path for the default repositories is reset to C:/PROGRA~2/CA/SERVIC~1/site/attachments/default/servicedesk/files.

Environment

Release : CA Service Desk Manager 17.X

Cause

There is a file, $NX_ROOT\data\docres.dat, and the path is stored in that file, which overwrites the data stored in the database.

Resolution

Locate the following in docres.dat:

 

{ "3" ,"C:/PROGRA~2/CA/SERVIC~1/site/attachments/default/archived_files" ,"0" ,"" ,"1" ,"0",

"Default Service Desk Repository" ,"0" ,"1002" ,"" ,"http" ,"1001" ,"0",

"" ,"1001",

"Service Desk" ,"C:/PROGRA~2/CA/SERVIC~1/site/attachments/default/servicedesk/files" }

 

Replace it with this:

 

{ "3" ,"C:/PROGRA~2/CA/SERVIC~1/site/attachments/default/archived_files" ,"0" ,"" ,"1" ,"0",

"Default Service Desk Repository" ,"0" ,"1002" ,"" ,"http" ,"1001" ,"0",

"" ,"1001",

"Service Desk" ,"your_path_here" }

 

 

 

You also need to modify docres.dat.tpl and replace this:

 

{ "3" ,"NX_ROOT_UNIX_STYLE_REPLACE/site/attachments/default/archived_files" ,"0" ,"" ,"1" ,"0",

"Default Service Desk Repository" ,"0" ,"1002" ,"" ,"http" ,"1001" ,"0",

"" ,"1001",

 

"Service Desk" ,"NX_ROOT_UNIX_STYLE_REPLACE/site/attachments/default/servicedesk/files" }

 

With This:

 

{ "3" ,"NX_ROOT_UNIX_STYLE_REPLACE/site/attachments/default/archived_files" ,"0" ,"" ,"1" ,"0",

"Default Service Desk Repository" ,"0" ,"1002" ,"" ,"http" ,"1001" ,"0",

"" ,"1001",

 

"Service Desk" ,"your_path_here" }

 

If you are still having issues, please open a ticket with CA Support.