Clarity: The % Complete values on the Task List and WBS view are rounding to either 0,00 or 100,00, why?
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Clarity: The % Complete values on the Task List and WBS view are rounding to either 0,00 or 100,00, why?

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Article ID: 50424

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When we add the % Complete field to either the Task List or WBS (Work Breakdown Structure) the values are rounding to either 0,00 or 100,00. 

If the tasks % complete is 0 to 49%, then on the view you see 0,00.

If the tasks % complete is 50 to 100%, then you see 100,00.

Alternatively, values seem multiplied by 100

Environment

Release: Any Supported Release

Cause

Caused by a non-US locale. This can happen on non English installations when OS locale is not set to US

Resolution

  1. Log into the CSA (Clarity System Admin) program
  2. Click on your server name
  3. Click on the Application link
  4. In the Application Instance: app enter the following in the Java VM Parameters field at the end: -Duser.country=US -Duser.language=en
  5. Save your change
  6. Stop and restart the clarity app service

Additional Information

Please also check Java Locale with Clarity