TDM Portal Upgrade Errors
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TDM Portal Upgrade Errors

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Article ID: 4991

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

While trying to upgrade the TDM web portal, I am running into these issues:

  • upgrade hanging 
  • ports in use errors 
  • uninstall of portal failing 

 

The first error in the TDM portal log file is: 

MSI (s) (50:38) [17:33:26:173]: SECREPAIR: Failed to open the file:C:\Users\<USER>\AppData\Roaming\CA\CA Test Data Manager Portal 4.x.x.x\install\disk1.cab for computing its hash. Error:2

Environment

TDM Portal 4.x+

Cause

These issues during TDM portal upgrade can be caused because there are remnants of the older code (services, files/folders, etc.) that have not been overwritten or replaced by the new files during the upgrade.

Resolution

Follow these steps to resolve the issues with the upgrade process. You need to have Administrator privileges on the system to perform these steps.

  1. Reboot the machine where TDM Portal has been installed.

  2. Delete the remnant services manually:
    To delete remnant services, at the Windows Command prompt type: SC DELETE <servicename> 

  3. Delete the CA TDM Portal folder (default location is "C:\Program Files\CA\CA Test Data Manager Portal").

  4. Run the TDM portal 4.x.x.x setup again.

Additional Information

If you face any issues following these steps, please open a support ticket through https://support.broadcom.com or by calling CA Customer Care using one of the numbers listed on this page: https://support.broadcom.com/web/ecx/contact-support.