Fresh Spectrum install: Can't access OneClick, or not all DSS landscapes are seen in OneClick console
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Fresh Spectrum install: Can't access OneClick, or not all DSS landscapes are seen in OneClick console

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Article ID: 4979

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

After a fresh install of Spectrum in test environment, we are seeing some communication issues. In some cases, we are unable to access OneClick via http in we browser. In other cases, we can access OneClick ok but some DSS landscapes are missing and not showing in the console, and not showing in Landscape Map. 

Spectrum is installed on fresh Linux RHEL servers. 

We have verified .hostrc files, etc/hosts files, and verified all known Spectrum Communication ports are clear in the network firewall. 

We check /SS-Tools/MapUpdate -view and not all Landscapes are showing in the map. 

Environment

DX NetOps Spectrum 10.x, 21.2, 22.2
RHEL 6.x, 7.x, 8.x

Cause

An internal firewall may still be preventing inter-server communication. 

Resolution

Temporarily disable internal firewall on all RHEL servers, and retest the connection: 

Perform the following commands as sudo, or logged in as root:

RHEL7 & RHEL8:

systemctl stop firewalld
systemctl disable firewalld

 

RHEL6:

service iptables stop

Additional Information

"service iptables stop" is a legacy command and does not run on RHEL7. It has been replaced with "systemctl stop firewalld".

Check with your system admin on firewall rules if you are having an issue connecting to OneClick in your production environment.