TPX definition for IBM Debug Tool (IBM Debugger) as application
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TPX definition for IBM Debug Tool (IBM Debugger) as application

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Article ID: 49761

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Updated On: 09-04-2024

Products

TPX - Session Management

Issue/Introduction

The session hangs when attempting to start a session for the IBM Debug Tool.

 

Environment

Release: 5.4

Component: TPX for Z/OS

Cause

The most common causes for this issue are:

- The IBM Debug Tool internally does a CLSDST and TPX cannot associate the second incoming BIND to an ACT entry.
The TPXLOG will show the message: 
TPXL0053 BINDLOST - NO ACT ENTRY FOUND - ACB= vtrm-ID, PLU=applid

- IBM Debugger needs to open up the applid from the batch job in order for TPX to pass the terminal over. TPX awaits for the batch to enable the applid for connection. If the applid is not available, the blank screen is received since no connection was established at that time.

Resolution

1) Use UNIQUE virtual terminal instead of a GROUP TYPE for this application.
This can be done by defining the IBM Debug Tool with TYPE=UNQ in the ACT.

2) Under user maintenance, the user should have a Transfer option of MULT.

3) Recommendation is to:
- start TSO on 1 TPX,
- then wait around 10 seconds (so that would give it enough time for the connection to be established),
- and only then start IBM Debugger on another TPX (emulator) session.

 

Note: TPX must be recycled to activate the changes from steps 1 and 2 above.