Error on registering the CA Process Automation Application

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Article ID: 4965

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Updated On:

Products

EMBEDDED ENTITLEMENTS MGR SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Service Desk Manager CA Process Automation Base

Issue/Introduction

When trying to register the CA Process Automation (ITPAM) application it triggers the following error:

Could not connect to EEM Server

Cause

The problem is caused by Embedded Entitlements Manager (EEM) having FIPS enabled, while ITPAM, by default, does not have it enabled.

This causes the following error in the iPoz.log file, found under \Program Files\CA\SC\EmbeddedEntitlementsManager\Logs, indicating it:

Bad signature: incompatible signature digest type in the request from host [LLK85SH20066:63586]. Server is running in [Fips_Mode_On] and request signature digest type is [ITECH_DIGEST_MD5]. FIPS does not support ITECH_DIGEST_MD5 digest type.  

 

 

Environment

CA Service Management r14.1Process Automation r4.3Embedded Entitlements Manager r12.51

Resolution

It is necessary to disable FIPS on EEM:

1. Stop the iTechnology service

2. Navigate to \Program Files\CA\SC\iTechnology

3. Edit file iGateway.conf

4. Change the following setting:

from: <FIPSMode>on</FIPSMode>

to: <FIPSMode>off</FIPSMode>

5. Start the iTechnology service

6. Next, start the ITPAM installation again and you are going to be able to register the application.