The SSG log reports SEVERE errors which state the following: java.lang.OutOfMemoryError: GC overhead limit exceeded.
The following may be observed in addition to the error noted above, but not in all cases:
Depending on the frequency of the error above, the CA API Gateway may or may not be able to handle requests. Requests may fail to be processed.
Available memory is exhausted. This can be confirmed with the output of this command: free -m
Performance may be slower than is typical for the environment.
Environment
This affects all versions of the CA API Gateway product.
Cause
The java.lang.OutOfMemoryError: GC overhead limit exceeded error is indicative of the CA API Gateway application spending too much time performing Garbage Collection to free up memory. If over 98% of the total time is spent doing Garbage Collection and less than 2% of the heap is recovered, this error will occur.
Resolution
Allocate more memory to the CA API Gateway Appliance via the instructions below:
Hardware or Virtual Appliance:
Allocate more memory to the appliance. If virtual, access to VMware will be required. A VMware administrator can perform this task.
Ensure it is running with the minimum requirements at the very least, likely needing double that in a production environment.
Restart the appliance (Gateway application will scale the heap size up to half the Gateways detected memory).
Software:
Allocate more memory to the appliance.
Ensure it is running with the minimum requirements at the very least, likely needing double that in a production environment.
Adjust the java heap size by modifying the file /opt/SecureSpan/Gateway/node/default/etc/conf/node.properties to include: node.java.heap=X
It is recommended that X = half the MBs of the Gateway's allocated memory.