How can I tell which SiteMinder Web Agent for IIS to use for my situation?

book

Article ID: 49230

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) AXIOMATICS POLICY SERVER CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

Description:

Given the variety of SiteMinder Web Agents for IIS in each release, how do I know which install package I should use?

Solution:

First you need to determine which IIS Web Server you are using; IIS 6.x or IIS 7.x, second would be the bit level of the Web Server; 32 bit or 64 bit, and third would be the Policy Server version and Service Pack.

  • If IIS 6.x, then use the "win" installer package that matches the bit level of the Web Server. This is the installer package without "iis" in the name (smwa-<major version>-<servicepack>-<cumulative release>-win<bit architecture>.zip).

    Please note that as per the Platform Support Matrices, the SiteMinder Web Agent protecting 32 bit Application Pools on 64 bit Web Servers and IIS as an RPwith IIS 6.x is not supported.
  • If IIS 7.x then the installer package to use would depend on the Policy Server version;

    • If your Policy Server is at 6.x or 12.0 SP2 CR-01 or less, then you will need to use the installer package for IIS 6.x as above.

      Please note the caveats above apply, as well as the fact this requires the "Classic" Pipeline mode.
    • If your Policy Server is 12.0 SP3 or later, then use the "iis/win" installer package that matches the bit level of the Web Server (sm-wa-iis-<major version>-<servicepack>-<cumulative release>-win<bit architecture>.zip).

      This installer is for IIS 7.x and supports both pipeline modes (Classic and Integrated), Application Request Routing - ARR (IIS as an RP), and 32 bitApplication pool on the 64 bit web Server.

Please remember your Policy Server's major version and service pack must meet or exceed your Web Agent's major version and service pack (formerly QMR).

Environment

Release:
Component: SMIIS