This workitem is no longer available because another user has accepted it

book

Article ID: 49163

calendar_today

Updated On:

Products

DIRECTORY CA Identity Manager CA Identity Governance CA Identity Portal CA User Activity Reporting

Issue/Introduction

Error message when trying to access an item in a worklist to approve in the workflow process:
"This workitem is no longer available because another user has accepted it."

 

Cause

By default, out of the box, the worklist can only show 100 items. If more than 100 items are set the following Error can be thrown:

"This workitem is no longer available because another user has accepted it." due to the same approval being approved by a different administrator

Environment

Release: 14.x
Component: IDMGR

Resolution

Raise the default workitem limit of 100 to a higher number by editing the following file:

Netegrity IdentityMinder.ear\workflow.rar\META-INF\ra.xml

<config-property>
<config-property-name>SQLQueryLimit</config-property-name> 	
<config-property-type>java.lang.Integer</config-property-type> 	
<config-property-value>100</config-property-value> </config-property> 

Note:
Raising this limit too high can cause performance degradation.

Additional Information

https://knowledge.broadcom.com/external/article?articleId=25822