Users are not able to login to Spectrum OneClick and receive the following error message: "No SpectroSERVER is available"
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Users are not able to login to Spectrum OneClick and receive the following error message: "No SpectroSERVER is available"

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Article ID: 49122

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

Users are not able to login to Spectrum OneClick and receive the following error message:

"No SpectroSERVER is available"

Environment

Release: Any
Component: SPCOCK

Cause

Possible root causes:

The SpectroSERVER is not running

OneClick pointing to the wrong Main Location Server (MLS)

Location Server is not running properly under processd

A communication issue between the MLS and the OneClick systems

Wrong adminUserName parameter in the $SPECROOT/tomcat/webapps/spectrum/META-INF/context.xml file

The OneClick host is not in the $SPECROOT/.hostrc file on the MLS

 

Resolution

The SpectroSERVER is not running

Ensure the SpectroSERVER processes is running on the MLS server

 

OneClick pointing to the wrong Main Location Server (MLS)

Check the locServerName parameter in the $SPECROOT/tomcat/webapps/spectrum/META-INF/context.xml file on the OneClick server is pointing to the MLS server


Location Server is not running or unable to be started by processd

Check if the locserv.exe process is running. If it is not, check its log at <SPECROOT>/LS/LOCSERV.OUT for possible root cause for failed start. 

Try starting Location Server process:
- nav to <SPECROOT>/bin
- run command: ./launchinstdbapp localhost LOCSERV y LOCSERV.OUT

If that does not solve the issue "No SpectroSERVER is available" then try restarting processd: 
- nav to <SPECROOT>/lib/SDPM
- run command: processd --stop
- run command: processd --start


A communication issue between the MLS and the OneClick systems

Verify hostname resolution between the MLS and OneClick and the OneClick and MLS servers

Ensure there are no firewalls or iptables (Linux) preventing communication between the MLS and OneClick servers. Reference the "Communication Across Firewalls" section of the documentation for information on what ports Spectrum requires for communication.

 

Wrong value for the adminUserName parameter in the $SPECROOT/tomcat/webapps/spectrum/META-INF/context.xml file

Verify the adminUserName parameter in the $SPECROOT/tomcat/webapps/spectrum/META-INF/context.xml file on the OneClick server is the username of the user that owns the Spectrum installation on the SpectroSERVER system. 

NOTE: To make the Spectrum administration easier across the entire Spectrum environment, it is recommended to use the same user name to own all of the Spectrum, OneClick and Spectrum Report Manager installations.

 

The OneClick host is not in the $SPECROOT/.hostrc file on the MLS

Check the $SPECROOT/.hostrc file on the MLS server and ensure the hostname or ip address of the OneClick system is present.