In CA Asset Portfolio Management 14.1, a data import fails with the error: 1. You cannot change the Asset Family for this model because there are assets based on this model. 2. Invalid hierarchy data entered for Class.

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Article ID: 4897

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Updated On:

Products

CA IT Asset Manager CA Software Asset Manager (CA SAM) ASSET PORTFOLIO MGMT- SERVER CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

In CA Asset Portfolio Management 14.1, a data import fails with the errors:  

1. You cannot change the Asset Family for this model because there are assets based on this model. 

2. Invalid hierarchy data entered for Class. 

Cause

This error occurs when the data import was written to update assets in a specific asset family, but the input data file contains some records in a different asset family. 

Environment

CA Asset Portfolio Management 14.1, any patch level

Resolution

There are a couple of options to handle this type of error:

1.  If you want the data import to remain restricted to a single asset family, then this error is valid and you'll want to remove the bad data records from the input data file.

2.  If you want the records with the different asset family updated with this import, then create a new data import map file that operates on 'across all families'.