Unable to connect to JIRA in Agile Designer due to 'http 0 unreachable' error message

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Article ID: 4896

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Updated On:

Products

CA Agile Requirements Designer

Issue/Introduction

When trying to connect to JIRA in Agile Designer I am receiving the following error message- http: 0 unreachable.

 

We are able to connect using web interface, and we are able to ping the JIRA server, but we cannot access from ARD. We are using SSL to access via web browser. The URL we are using has the following format: https://localhost.atlassian.com 

We used these debugging instructions to receive error messages in the log file: https://knowledge.broadcom.com/external/article?articleId=45923
We are looking at this documentation to try and connect: https://techdocs.broadcom.com/us/en/ca-enterprise-software/devops/agile-requirements-designer/2-10/integrations/integration-with-lifecycle-tools/integrate-with-jira.html

Cause

The reason you are seeing this error message is because the URL being used to connect to JIRA through ARD is incorrectly formatted. It could be that the URL is pointing to the wrong location, the port is missing, or the API for JIRA is turned off. SSL is not a problem if the URL starts with 'https'. 

Environment

 

Release : all releases

Component : CA Agile Requirements Designer - Atlassian's JIRA

Resolution

In this specific instance, the URL was formatted incorrectly because the port was missing. Adding the port resolved the issue. 

Here is how to connect to JIRA from within Agile Designer: 

  1. Select Connectors, Atlassian JIRA from the Toolbox.
  2. Enter the JIRA instance URL and your JIRA username and password. 
    Example: http://localhost:8095

 

Once you have logged in successfully, you will either see your JIRA projects or a 'Setup Configuration' button if you have no projects mapped yet.

This document outlines setting up the configurations and exporting test cases to JIRA: 

Additional Information

If you experience any further issues, please open a support case by going to https://casupport.broadcom.com/user/ or https://www.ca.com/us/services-support/ca-support/contact-support.html?intcmp=footernav.

Attachments

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