Eclipse Plugin errors after install

book

Article ID: 48893

calendar_today

Updated On:

Products

CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

Description:

After installing the Eclipse plugin the user gets two errors:

  1. CA SCM Team Provider 12.1.3.309a (com.ca.harvest.team 12 .1.3.309a) requires 'bundle org.eclipse.birt.chart.engine 0.0.0' but it could not be found

  2. Failed to initialize CA SCM CMSDK. Please ensure that all required components are installed.

Solution:

  1. First of all, restart your system after installing the Harvest on the machine and check if the error appears again.

  2. The Eclipse plugin depends on certain dlls installed with either the CA SCM Workbench or the CA SCM Client. Check to see that the SCM Client or Workbench is installed and then the library error message should be gone.

Please check that your machine meets the following requirements:
-------------------------------------------------------------------------------------------

  • Windows 32-bit client
    CA SCM Plug-in for Eclipse r12 has the following system requirements for
    Windows 32-bit clients:
    1 CPU Pentium IV 1.3 GHz
    1 GB RAM
    250 MB free hard disk space

  • Java Runtime requirement
    Eclipse does not come with a Java virtual machine (JVM), so one must be
    downloaded and installed separately prior to installing the plug-in. The following versions of the JRE are supported:
    Java 5 JRE (Sun)
    Java 6 JRE (Sun)
    IBM JRE is already included with IBM Rational Application Developer 7.0

  • Web Browsers
    The following web browsers are supported:
    Microsoft Internet Explorer 6.0 and 7.0
    Firefox 3.0

  • The r12 Eclipse plug-in is not supported on the 64-bit version of the Eclipse IDE. You must download the win32-bit version of the IDE.

How to Perform a First-Time Installation
-----------------------------------------

If you are installing the Eclipse plug-in for the first time, perform the following pre-installation tasks:

  1. Install the CA SCM client (Workbench or command line) on each computer where the plug-in will be installed.

  2. Install the Java Runtime (JRE) on your computer.

  3. Install Eclipse in a location that will be used specifically for your r12 plug-in. It should not be used with any prior release plug-in.

    Note: The Eclipse version must be downloaded from http://www.eclipse.org and installed on the target systems prior to installing the plug-in.

  4. If the Eclipse Graphical Editing Framework (GEF) feature is not already installed in your Eclipse component, you need to install it. If you do not have it installed, you will receive an error message during the plug-in installation and not be allowed to continue.

    Note: For installation instructions, see http://www.eclipse.org/gef/.

  5. Consider whether you will run r7.1 and CA SCM r12 on the same client computer. If you plan to run both the r7.1 and r12 client and plug-in on the same computer, review and perform the coexistence steps (see page 28) prior to installing the r12 plug-in. For this configuration, you will need separate installations of Eclipse for r7.1 and r12 plug-ins, respectively.

  6. Proceed to install the CA SCM Plug-in for Eclipse.

    Install the CA SCM Plug-in for Eclipse

    Steps under CA Software Change Manager Plug-In for Eclipse Release Notes

    Chapter 5: Installing the Plug-in for Eclipse Page 27

Environment

Release: SCMNCR99000-12.1-Harvest-Software Change Manager-Named User-Competitive Replacem
Component: