CAUAJM_E_10127 CA WAAE Application Server cannot use port [7500]

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Article ID: 4867

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Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation Agent

Issue/Introduction

 

During the startup of the Application Server, I am getting this error message:

CAUAJM_E_10127 CA WAAE Application Server cannot use port [7500] as an auxiliary agent listener port because it has been configured through the CA Secure Sockets Adapter.

Cause

 

Port 7500 was set by error in the SSA configuration by running the $CSAM_SOCKADAPTER/bin/csamconfigedit command.

For example: $CSAM_SOCKADAPTER/bin/csamconfigedit port=7500 enablepmux=true

Result of this command is that file $CSAM_SOCKADAPTER/cfg/APPF-GLOBAL-7500 is present in that directory

 

Environment

CA-WAAE 11.3.6 on LinuxIt might happen on any other Unix platform

Resolution

 

To resolve this problem, you have to

- stop all the CA-WAAE services with "unisrvcntr stop CA-WAAE"

- stop SSA with "$CSAM_SOCKADAPTER/bin/csampmux stop"

- remove file $CSAM_SOCKADAPTER/cfg/APPF-GLOBAL-7500

- start SSA with "$CSAM_SOCKADAPTER/bin/csampmux start"

- start CA-WAAE services with "unisrvcntr start CA-WAAE"