Operation is not allowed for a Rollup. Unselect Rollup and try again. [SDG032425]
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Operation is not allowed for a Rollup. Unselect Rollup and try again. [SDG032425]

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Article ID: 4859

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Patch Manager

Issue/Introduction

I am trying to deploy a packaged IntelliRollup by drag and drop directly onto a computer in DSM Explorer

this fails with:

  • Operation is not allowed for a Rollup. Unselect Rollup and try again. [SDG032425]

How can I deploy the rollup to computers through DSM Explorer?

Environment

Client Automation - All versions

Cause

This is working as designed. The package of type Rollup was created for IntelliRollups

It contains the dms scripts used to ascertain which patches are required on the target PC and to schedule the install of these patches.

As this package does not contain the patches themselves there is no point in deploying this and thus the DSM explorer does not allow it. 

You can find the structure of an IntelliRollup documented here: Intelligent Roll-up Delivery

 

Resolution

Each IntelliRollup is registered to Software Delivery as a special Software Delivery group of type Patch Rollup.

To deploy this to a target agent via DSM Explorer you follow the 2 steps below

  • Stage this group to the Scalability Server Software Library
    • This is essential. The individual patches must all be in the SS's library to allow the script to order their installation.
    • If you try to deploy to an agent when this is not staged the job will fail with the error
      • "Job execution error, one or more software packages required by the agent are not staged."
  • Deploy this group to the target agent, either by drag and drop or right click deploy