"Found more than one user with userid" in view.log When Submitting A Form In Service Catalog
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"Found more than one user with userid" in view.log When Submitting A Form In Service Catalog

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Article ID: 4854

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Updated On:

Products

CA Service Catalog CA Service Management - Service Desk Manager

Issue/Introduction

Problem 1:

The following error appears in view.log when submitting a form in Service Catalog:

2016/11/14 15.34.03.566 WARN [http-bio-8080-exec-309] [ContactHelper] Found more than one user with userid:<example-userid>
2016/11/14 15.34.03.566 ERROR [http-bio-8080-exec-309] [DocumentGenerator] Error occurred: null
java.lang.NullPointerException


Problem 2:

Requests for a specific user are repeated four times in the search list and the details of the request are not displayed.

Environment

Service Catalog 14.1 and later

Cause

There are duplicates userid's in the ca_contact table. This might be caused by multiple ldap imports in Catalog and/or Service Desk Manager

Resolution

The duplicate userid's may exist only when 1 is active and the other is inactive. Identify and rename the duplicated userid's. This can be done from:

1) Database level by running: select userid, count(*) from ca_contact group by userid having count(*) > 1

2) CA Service Desk Manager > Security and Role Management > Contacts Search for active and inactive users > Locate the duplicate userid's.

3) Once the duplicates are identified, rename the inactive userid's and this will solve the issue.