How to move or replace a Data Collector (DC)
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How to move or replace a Data Collector (DC)

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Article ID: 48474

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Updated On:

Products

CA Performance Management Network Observability

Issue/Introduction

In the Data Collector (DC) list under Administration->Monitored Items Management->Data Collectors on the DX NetOps Portal, the Data Collector has the status "Unknown" after attempting to reinstall or migrate.
There is a second data collector with a connected status, but it has no polled items.

Environment

DX NetOps Performance Management, all supported releases.

Cause

Not using the dcmid of the original data collector when migrating/reinstalling the Data Collector   

Resolution

You need to utilize the DCM_ID variable populated with the dcmid of the Data Collector (DC) you are reinstalling/migrating per the documentation:

Reinstall or Migrate the Data Collectors

For specific steps see the Reinstall the Data Collector on a Clean Host documentation topic on the same page.

Additional Information


1) The dcmid will be in the format of:

<DcmID>hostname:########-####-####-####-############</DcmID>

The hostname is part of the id. This cannot be changed or omitted on the new DC host. The hostname here is part of the dcmid and does not need to match the hostname of the server you are moving to. 

2) The configuration for the data collector is kept on the data aggregator (DA) so when the newly installed DC contacts the da with the old DCMID the da will send the configuration.