The pre-check installation returns the error: Unable to retrieve DB Timezone, refer to checkinstall.log for details when upgrading.
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Article ID: 4847
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Updated On:
Products
Clarity PPM SaaSClarity PPM On Premise
Issue/Introduction
The pre-check installation returns the error: Unable to retrieve DB Timezone, refer to checkinstall.log for details when upgrading to v14.2 to 15.1
This will happen with customers that are in the GMT timezone. It does not happen when the timezone is changed to any other time zone apart from GMT
Steps to Reproduce:
On the CA PPM server set the timezone to (UTC) Dublin, Edinburgh, Lisbon, London
On the MS SQL Database server set the timezone to (UTC) Dublin, Edinburgh, Lisbon, London
Set the clock to a GMT date for both CA PPM & Database server
Extract the install.jar from the CA PPM 15.1 installation media
Run the Install.bat/.sh
Environment
CA PPM 14.2, 14.3,14.4,15.1
Cause
This is identified as but CLRT-81590 and its in review with our engineering team
Resolution
To adjust the DB & CA PPM server timezones to non-GMT timezones then continue the upgrade. Changed back to the GMT Timezone after the upgrade has been successful.
Or
Navigate to the <Install Media>\checkinstall\ folder
Modify .\checkinstall\checkinstall-config.xml to comment out this line as shown below: <!-- <checkscript filename="check-timezones.xml" operations="UPGRADE" environments="OP" phases="BEFORE" bypass="false"/> -->
Run the install.bat/.sh to proceed with the upgrade.