Differences Between Rally Sandbox and Production Environments
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Differences Between Rally Sandbox and Production Environments

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Article ID: 47862

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Updated On:

Products

Rally SaaS

Issue/Introduction

A number of different services aren't available in Sandbox.

Environment

Sandbox Availability

Support can run Sandbox refreshes per customer request.  When these refreshes are run the Sandbox environment will be temporally unavailable for all customers. 

Sandbox status will be posted at https://status.broadcom.com/services/rally for current sandbox status. 

Rally Software's Sandbox does not fall under the SLAs for CA Agile Central production. There's no contractual uptime agreements or SLAs for the Sandbox environment. However, we have an operational working agreement to keep Sandbox up during business hours (8 AM - 5 PM Mountain time, Monday-Friday) and to avoid downtime prior to 6 PM (Mountain) unless absolutely necessary. We make our best effort to avoid downtime during peak business hours.

Customers accessing Rally production on the European datacenter (https://eu1.rallydev.com) do not have access to a Sandbox instance at this time. 

Customers accessing the Rally FedRamp environment  (https://gov.rallydev.com/) do not have access to a Sandbox instance at this time.

Cause

Rally Sandbox environment offers a subset of services from Rally Production.

Resolution

Because Rally's Sandbox environment is a subset of the SOA (Service Oriented Architecture) present in Rally production, a number of different services are not available in Sandbox (https://sandbox.rallydev.com):

  1. Single Sign On (SSO)
  2. Lookback API
    • Project Cumulative Flow Chart
    • Portfolio Item Burnup
    • Other Lookback-based charting
    • Search Functionality
  3. API Key, OAuth
    • The "zuul" service on which API key and OAuth relies, is not present in Sandbox.  Users have two options for logging in:
    • Rally username/password
      • To login with username/password the user will need to navigate to this URL to create their password https://sandbox.rallydev.com/slm/resetPassword.tr if they don't have a password already for the Sandbox environment.   
    • API Key,
      • please reference this help article: API Keys
  4. Watches and watch-based notifications
  5. jGopher and PG Search
  6. Webhooks/Pigeon.
  7. Backups - the Sandbox DB is not operationally backed up
  8. Feature Toggles
    • By default, functionality that is "turned on" in Rally Production but is behind a feature toggle, is not enabled in Sandbox. Once a feature is released as GA in production and no longer behind a feature toggle, it will usually become available in sandbox.
  9. Proof which serves the reports on the Reports > Reports page and the related Apps from the App Catalog.  Please Note:  Reports & Apps will show, "There was a problem connecting to the service.  No data available. -Status 404."
  10. Garthe and related services
    • FCA timesheet calculations 
    • All functionality with charts 
  11. All AI functionality 
  12. ICE integration 
    • Helpbot

 

 



Additional Information

Note: Refreshes can’t be scheduled on Thursday nights due to a snapshot of Sandbox is being mounted every Thursday at 12 AM MT and DBA’s run its backup of Sandbox on Thursday Night.