Timesheet Reports or DWH missing data when slices are not fully processed
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Timesheet Reports or DWH missing data when slices are not fully processed

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Article ID: 47682

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The Jaspersoft Timesheet reports such as the below are not accurate and/or are missing data for a particular date range.

  • Missing Time
  • Timesheet Detail
  • Resource Time Summary and Detail

The Data Warehouse (DWH) does not display the time entry hours for this date range in the adhoc view/reports either.

Environment

All Clarity versions

Cause

This is due to the Time Slicing job not fully processing the time slice id 55555 - DAILYRESOURCETIMECURVE

Resolution

Step 1: Review Fiscal Time Periods

Ensure the fiscal time periods exist and are activated for the date range in question.
To do this, go to: Administration > Finance > Settings > Entity > Fiscal Time Period

Make sure all fiscal time periods such as annually, monthly and weekly are present and active for current time period.

 

Step 2: Review the DWH Time Slices

Review the DWH Time slices required are within the date range request.

  1. Go to Administration > Data Administration > Time Slices
  2. Review the common time slices below to make sure they are in the desired range
  3. Check time slice id = 55555 DAILYRESOURCEAVAILCURVE
  4. Check time slice id = 1 DAILYRESOURCEAVAILCURVE
  5. If not, reslice each of the above IDs by modifying the following fields:
    1. Set "Number of Periods" to be the desired number of periods.
    2. Clear out the "Expiration Date"
    3. Click Submit.

Step 3: Run the applicable sequence of jobs

  1. Time Slicing job
  2. Update Report Tables job with all parameters check marked
  3. Load DWH job with "Full" parameter check marked 

Step 4: Check the BG Logs

If the above two slices are already coving the time periods in question, check the bg-ca log for blobcrack errors.