Kanban and Agile
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Kanban and Agile

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Article ID: 47662

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Updated On:

Products

Rally On-Premise Rally SaaS

Issue/Introduction

We've noticed that Kanban is becoming more and more a first attempt method for those starting their Agile transformation. While this is exciting, it's also concerning because Kanban is not an entry level methodology, and we want to make sure you're prepared.

It's rather advanced requiring great discipline from the team and the business and it's measured completely differently from Scrum (though there are compares).

 

Environment

Release:
Component: ACPREM

Cause

If you think of Scrum as White Belt through about Blue Belt

And Kanban as Purple and above, you begin to get a sense of the maturity teams and organizations need in order to do KanBan Successfully.

Why is this?  What's that magic tipping point?

That's hard to answer directly; but I can speak to where it fails new teams and businesses time and again.

It fails when organizations adopt it because they can model their current development streams, using slightly different, Agile-ish, names as the States.  Most often, the thought is that it will help teams adjust to the new way when the reality is that it enforces all the old ways under Agile conditions.

This ruins teams, fails in the transformation of the organization, and significantly retards that businesses ability to evolve in an ever faster delivery world.

 

Resolution

No, Kanban is not the cool new kid who knows Karate and will teach it to anyone interested. 

Kanban is in the dojo waiting for those who show the patience and wisdom to unlock its mysteries.

Proper uses are for teams that are interrupt driven (support organizations, product defect teams, etc.) or for mature teams that understand their processes and want to move to continuous delivery.

Key Details of Kanban in Rally

  • Configurable to the project or for the whole workspace
    • Multiple apps and configurations allowed
  • Adopts Iteration and release filters from custom pages
  • Stories and defects must be scheduled into releases in order to not display in the Accepted (or final state) column
  • Custom fields for Kanban and Swimlane use must exist in both the User Story and Defect Work Item
    • The name and contents of the drop down must be the exact same for each field in Defect and User Story
  • Reporting is built into the app
    • Cycle/Lead Time
    • Throughput
  • Allows for Queries in the settings
  • Default Swimlanes available OOTB
    • Expedite
    • Blocked
    • Owner
    • Sizing
  • Age can be shown on cards


Contact your Customer Success Manager if you have questions or need assistance