Why are the Line Feed characters in our CA Automation Point email notifications not displaying in the email body received?
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Why are the Line Feed characters in our CA Automation Point email notifications not displaying in the email body received?

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Article ID: 4760

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Updated On:

Products

Automation Point

Issue/Introduction

We have code that runs on Automation Point that gathers stats, and then updates a spreadsheet and sends an email to users. Before our upgrade to 11.5, the email message body looked like this: 

- NM CALLING - 
aaaaaaa 00001 68.1 
bbbbbbb 00033 80.0 
ccccccc 00001 79.2 
ddddddd 00001 89.1 


After the 11.5 upgrade, the message body now looks like this: 

- NM CALLING - This is item number 5660 - aaaaaaa 00001 59.3 bbbbbbb 00033 79.7 ccccccc 00001 79.2 ddddddd 00001 89.0 



So, the line feed code that worked in AP version 11.4 does not work in AP version 11.5. 

What has changed in the new release that is removing the LF characters in the email message body?

Environment

Microsoft Outlook Email Client

Cause

What we learned while investigating this case is that the CA Automation Point end-user's site was migrating from Lotus Notes to Microsoft Outlook enterprise-wide, and that Microsoft Outlook email client removes line breaks in the message body of plain-text messages by default. Since the end-user's REXX programs has these extra line breaks, and Outlook removes them by default, the LF characters are removed from the message body and it appears as one long line string of characters.

Resolution

The best approach is to request that your email recipients disable the "Remove Extra Line Breaks in Plain-Text Messages" option in your Outlook client.

Additional Information

Read this article for instructions about HOW-TO disable the "Remove Extra Line Breaks in Plain-Text Messages" option in your Outlook client application.