Using the "default" object manager or domsrvr with a given webengine
search cancel

Using the "default" object manager or domsrvr with a given webengine

book

Article ID: 47220

calendar_today

Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

When creating a new webengine in a Service Desk Conventional Configuration, you may notice that the "Object Manager" field can be set to "Default".

Is it a good idea to choose the "Default"? What impacts if I do that?

 

 

Environment

Release: CA Service Desk Manager 17.X

Cause

 Webengines require access to at least one Object Manager, or domsrvr, in order to function correctly.  What happens when you choose the "Default" setting for Object Manager on a given webengine is that the given webengine will then be tied to the primary server's domsrvr.  This is considered to be the "Default" domsrvr as it is always defined in all Conventional Configurations of Service Desk. 

The danger of using this domsrvr appears if one were to define multiple webengines and tie them all the same "default" domsrvr, which will cause the given domsrvr process to become overloaded with all of the webengines' object requests, and can lead to severe performance degradation. And in case like this, you won't see much in stdlog file and you would see a lot of objects(like over 100 thousands) listed in

bop_cmd -f /opt/CAisd/bopcfg/interp/bop_diag.frg "dump('')"

which means the domsrvr is too busy and in turn the users will see slowness in the app and in some extreme cases users may think the app is down.

 

 

Resolution

 The ideal approach is to create a domsrvr on the same server as the webengine and have the given webengine tied to the local domsrvr.

To do this:

    1. Create a new domsrvr on the given secondary server
    2. Go into the webengine that was created on the same secondary server.  Under the Object Manager dropdown, choose "Update Object Managers"
    3. Do a search for the domsrvr you just created on the secondary server
    4. Add that domsrvr to the webengine.



 

Additional Information

The following tech doc describes how to add a secondary server using the Administrative Web Interface for creating configurations in SDM 12.9 onwards.

Set up a Service Desk Manager secondary server using the Administrator Web Interface