Unable to login into WCC. Results in Error "E150005: Login timed out."
search cancel

Unable to login into WCC. Results in Error "E150005: Login timed out."

book

Article ID: 4722

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent

Issue/Introduction

When we try logon to the CA Workload Control Center (CA WCC) User Interface, it results in error:

E150005: Login timed out.

Environment

WCC 11.3.5, 11.3.6 & 11.4 on Linux/Unix

Cause

We find following error messages in CA-wcc.log:

Caused by: org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [http://<host>:10132/wcc-configuration/cfmremote/remoteGlobalPrefService]; nested exception is com.ca.wcc.config.api.exceptions.WCCException: Did not receive successful HTTP response: status code = 500, status message = [Internal Server Error]

 

We also see following error messages in CA-wcc-services.log:

[] ERROR #BaseLoopImpl # Hazelcast Instance is not active! 

java.lang.IllegalStateException: Hazelcast Instance is not active!

INFO | jvm 1 | 2017/03/04 20:11:22 | SEVERE: Servlet.service() for servlet [remoteservices] in context with path [/RemoteServices] threw exception [Handler processing failed; nested exception is java.lang.OutOfMemoryError: Java heap space] with root cause
INFO | jvm 1 | 2017/03/04 20:11:22 | java.lang.OutOfMemoryError: Java heap space
INFO | jvm 1 | 2017/03/04 20:11:22 |
INFO | jvm 1 | 2017/03/04 20:11:22 | Mar 04, 2017 8:11:22 PM org.apache.catalina.core.StandardWrapperValve invoke
INFO | jvm 1 | 2017/03/04 20:11:22 | SEVERE: Servlet.service() for servlet [remoteservices] in context with path [/RemoteServices] threw exception [Handler processing failed; nested exception is java.lang.OutOfMemoryError: Java heap space] with root cause
INFO | jvm 1 | 2017/03/04 20:11:22 | java.lang.OutOfMemoryError: Java heap space
INFO | jvm 1 | 2017/03/04 20:11:22 |

Resolution

Perform the following steps to address the OutOfMemory: Java heap space problem with CA WCC services:

1. Stop CA-wcc, CA-wcc-services services

2. Take a backup copy of and edit the %CA_WCC_INSTALL_LOCATION%\tomcat_32\conf\wrapper.conf file ($CA_WCC_INSTALL_LOCATION/tomcat_32/conf/wrapper.conf, on Linux/UNIX) and change the following:

    From:

    wrapper.java.maxmemory=812

    To:

    wrapper.java.maxmemory=1600

Note: This value is associated with the Tomcat server for the CA WCC 32-bit service. The maximum and recommended value is 1600 on Windows and 1900 on Linux/Unix (2GB).

3. Take a backup copy of and edit the %CA_WCC_INSTALL_LOCATION%\tomcat\conf\wrapper.conf file ($CA_WCC_INSTALL_LOCATION/tomcat/conf/wrapper.conf, on Linux/UNIX) and change the following:

    From:

wrapper.java.maxmemory=2048

    To:

wrapper.java.maxmemory=4096

4. Start CA-wcc, CA-wcc-services services back up.

Additional Information

CA Workload Control Center: Performance Tuning