ITAM cannot connect to ITPAM over SSL
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ITAM cannot connect to ITPAM over SSL

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Article ID: 46920

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Updated On:

Products

CA IT Asset Manager CA Software Asset Manager (CA SAM) ASSET PORTFOLIO MGMT- SERVER CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When integrating ITAM with ITPAM configured for SSL, getting the error below in EventService.log:

The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel".

Environment

Asset Portfolio Management 17.x

Cause

The ITPAM certificate has not been registered in Trusted Root Certificate Authorities of ITAM Server at Local Computer level.

Resolution

  1. Follow the instruction from the below page to reconfigure ITPAM with a new certificate:
    IMPORTANT: when creating the certificate you will be asked "What is your first and last name?", this is where you should type the ITPAM machine name.

    Manage Certificates for ITPAM 4.3.05 

    Manage Certificates for ITPAM 4.4

  2. After PAM is configured with the certificate, access PAM from the ITAM machine using Internet Explorer. Accept the Certificate Error warning, click on the padlock near the address bar, click View Certificate, click Install Certificate, select 'Local Machine', click Next, select 'Place certificates in the following store', click Browse, select 'Trusted Root Certificate Authorities', click OK, Next, Finish.

  3. Check using Microsoft utility mmc that the ITPAM certificate has been registered for Local Computer and not for the connected user only  If you don't find the Certificate in Trusted Root Certificate Authorities  of Local Computer , copy it from Current user into Local computer.

  4. Execute iisreset command in the ITAM machine and restart Event Service.

  5. Test connection to PAM in ITAM by creating a new event.