Problem accessing trust store
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Problem accessing trust store

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Article ID: 46637

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

Problem:

While starting the SOI Manager the following error message is occurring in the soimgr.log:
java.lang.IllegalStateException: Failure initializing default SSL context
...
Caused by: java.security.KeyStoreException: problem accessing trust storejava.io.IOException: Keystore was tampered with, or password was incorrect.

The password and the path to the keystore file in the file \CA\SOI\jsw\conf\soi-manager.properties are correct.

keytool.exe -list -keystore d:\ca\soi\tomcat\conf\ssa.jks returns the expected output using the same password.

 

Environment:

SOI 4.0 upgraded from SOI 3.3 CU2

 

Cause:

During the upgrade from 3.3 CU2 to SOI 4.0 the wso2registry folder containing the file below with the custom keystore password
is backed up to a folder named wso2registry.bak.


- \CA\SOI\wso2registry\repository\conf\carbon.xml

this file is replaced with a carbon.xml file containing the default "catalyst" password

 

Resolution:

Change the password for the keystore and truststore (not the privatekey password) in the carbon.xml file and recycle the SOI Manager services.

 

Additional Information:

 

In 4.0 there are entries for the keystore and the truststore. The passwords must be set in a clear text format.

Environment

Release: SAMBDL99000-3.3-Spectrum-Service Assurance Manager-Promotional Bundle
Component: