Two of our four lpars are ignoring the defined CCI ports and the connections are failing
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Two of our four lpars are ignoring the defined CCI ports and the connections are failing

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Article ID: 46629

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Updated On:

Products

CIS COMMON SERVICES FOR Z/OS 90S SERVICES DATABASE MANAGEMENT SOLUTIONS FOR DB2 FOR Z/OS COMMON PRODUCT SERVICES COMPONENT Common Services Datacom/AD CA ECOMETER SERVER COMPONENT FOC Easytrieve Report Generator for Common Services INFOCAI MAINTENANCE IPC UNICENTER JCLCHECK COMMON COMPONENT Mainframe VM Product Manager CHORUS SOFTWARE MANAGER CA ON DEMAND PORTAL CA Service Desk Manager - Unified Self Service PAM CLIENT FOR LINUX ON MAINFRAME MAINFRAME CONNECTOR FOR LINUX ON MAINFRAME GRAPHICAL MANAGEMENT INTERFACE WEB ADMINISTRATOR FOR TOP SECRET Xpertware Compress Data Compression for MVS Compress Data Compression for Fujitsu

Issue/Introduction

CCI is used on all 4 of our LPARS, 2 production and 2 test.  
They are all connected to each other and the CCI parms defined on them are the same.

Prod:  SYSp1,SYSp2
Test:   SYSt3,SYSt5

Recently, SYSp1 and SYSt5 began to use the default port number of 1721 instead of the defined port of 7000 and the connections failed.   

We use the following parms:  

SYSp1 CCI parm:
SYSID(CCISYSp1)
PROTOCOL(TCPIPGW,7000,1,CCISYSp1)
NODE …………

SYSp2 CCI parm:
SYSID(CCISYSp2)
PROTOCOL(TCPIPGW,7000,1,CCISYSp2)
NODE …………

SYSt3 CCI parm:
SYSID(CCISYSt3)
PROTOCOL(TCPIPGW,7000,1,CCISYSt3)
NODE …………

SYSt5 CCI parm:
SYSID(CCISYSt5)
PROTOCOL(TCPIPGW,7000,1,CCISYSt5)
NODE …………


SYSp1 CCITCPGW log:
IEF695I START CCITCPGW WITH JOBNAME CCITCPGW IS ASSIGNED TO USER CCITCPGW GROUP
$HASP373 CCITCPGW STARTED
IEF403I CCITCPGW STARTED - TIME=13.13.54
BPXP022E ONE OR MORE JOBS ARE WAITING FOR UNIX SYSTEM SERVICES AVAILABILITY
CAS9075I - Service(CA-CCI/BASE) Vers(1500) Genlvl(F000AW400)
CAS9899W - CCISSLGW could not obtain its CCI SPAWN parameters (rc = A0000450) - Using Defaults
CAS9899I: Maximum # of Connection Threads = 4999
CAS9850I - CCI TCP/IP Protocol Driver CCITCPGW Starting
CAS9850I - CCI Sysid Name = CCISYSp1
CAS9899I - Only Unsecured Connections Allowed
CAS9899W - TCP/IP Not Available...waiting
CAS9850I - CCI/SSL ActiveCAS9850I - CCI TCP/IP Protocol Driver Ready.
CAS9850I - CCI TCP/IP Host Name = SYSp1
CAS9850I - Port = 1721

 

SYSp2 CCITCPGW log:
IEF695I START CCITCPGW WITH JOBNAME CCITCPGW IS ASSIGNED TO USER CCITCPGW GROUP
$HASP373 CCITCPGW STARTED
IEF403I CCITCPGW STARTED - TIME=13.33.31
BPXP022E ONE OR MORE JOBS ARE WAITING FOR UNIX SYSTEM SERVICES AVAILABILITY
CAS9075I - Service(CA-CCI/BASE) Vers(1500) Genlvl(E000AW400)
CAS9899I: Maximum # of Connection Threads = 4999
CAS9850I - CCI TCP/IP Protocol Driver TCPIPGW Starting
CAS9850I - CCI Sysid Name = CCISYSp2
CAS9899I - Only Unsecured Connections Allowed
CAS9899W - TCP/IP Not Available...waiting
CAS9850I - CCI/SSL Active
CAS9850I - CCI TCP/IP Protocol Driver Ready.
CAS9850I - CCI TCP/IP Host Name = SYSp2
CAS9850I - Port = 7000

 

The log for SYSt3 matches that of SYS2 and the defined parms are being used.  However, the log for SYSt5 matches that of SYSp1 and the defined parms are ignored. The default port number of 1721 is being used and the connections fail.  

 SYSp1 and SYSt5 are the two systems where the problem appears.  The ENF logs for these two systems display the following when CCI is started:

S CCITCPGW
OPSNOTIFY Start request of SSM managed resource CCITCPGW processed.

Additionally, the CCI log for SYSp1, and reportedly matched by SYSt5, also display the following messages:

CAS9075I - Service(CA-CCI/BASE) Vers(1500) Genlvl(F000AW400)
CAS9899W - CCISSLGW could not obtain its CCI SPAWN parameters (rc = A0000450) - Using Defaults

The messages that follow the CAS9899W message also show that the port has been changed to 1721 and the CCI parms are being ignored.

The CAS9899W message will be issued when either:
      • ENF does not start the CCI task
              o     Possibly CCI was recycled and restarted outside of ENF (using modify commands)
      • Something other than ENF is starting and managing the CCI task

The ENF log for these systems show that the latter is the case based upon the OPSNOTIFY message previously noted.  

Compare this to the CCI log listed above for SYSp2 and reportedly matched by SYSt53, these two systems do not have the problem.   The CAS9075I message is followed by the settings that are defined in the CCI parms for both systems.  

 

 

Environment

Release:

CA Common Services v15.0 for z/OS  

Component: CAICCI using CCITCPGW with CA OPS SSM installed

Cause

The CCITCPGW tasks were started and managed by CA OPS SSM rather than ENF which severed the connection between ENF and the CCI tasks.

Resolution

Anything interfering with the ENF startup and management of CCI will ignore the settings for port/protocol and sever any connections. 

  • The CCITCPGW tasks need to be excluded from OPS SSM startup and management.  
  • CCI needs to be started and managed by ENF 
    • CCI uses the port and protocol defined by the CCI parms
      • which set the TCPIPGW port to 7000.  

Additional Information

Refer to the Common Services r15.0 documentation for details of the operation of CAICCI and the CAS9899W message.