Unable to get the performance counter values with the CDM probe on a window Server
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Unable to get the performance counter values with the CDM probe on a window Server

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Article ID: 46605

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Unable to get the performance counter values with the CDM probe on a window Server. You may see errors similar to the following in the cdm.log file at log level 5:

cdm: GetNameStrings - lastcounter = 8958
cdm: GetNameStrings - Open registry local machine key SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\009
cdm: GetNameStrings - Query registry info on opened key
cdm: GetNameStrings - largest value = 0
cdm: GetNameStrings - Query registry value of Counter
cdm: Error from GetNameStrings - RegQueryValueEx (Counter): The system cannot find the file specified

 

Environment

Any version of UIM and cdm

Cause

The cdm probe fetches performance objects for Processor, Memory and System directly on Windows servers (Windows perfmon utility). If the probe is not able to retrieve the values of these counters, QoS metrics cannot be collected.

Resolution

Follow the below step:-

== Go to the regedit and check the counter is available under HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Perflib\009.

== If counter is not available, you have to manually rebuild the performance counters.

== Go through the below link for “how to manually rebuild the performance counter library values “.

https://support.microsoft.com/en-us/kb/300956

Additional Information

The cdm probe monitors CPU, disk and memory parameters to detect performance bottlenecks.