Unable to launch policy manager with Access Denied error.
search cancel

Unable to launch policy manager with Access Denied error.

book

Article ID: 46530

calendar_today

Updated On:

Products

CA API Gateway

Issue/Introduction

Issue:

Unable to launch policy manager as the access is denied from creating files to Administrator user data area and the launch fails with below error in the screenshot.

Environment

All supported versions of the Policy Manager

Cause

Unable to run policy manager on windows system. Install runs fine but on startup it tries to create files (truststore) in Administrator user data area which it doesn't have access to.

 

Resolution

The easiest way to fix this would be to move the installed .l7tech folder to a location you know you'll have access to (for example c:\temp) and then edit the Layer 7 Policy manager.ini file and add the below to it somewhere near the other -Duser
-Duser.home="c:\temp\.l7tech"

Attachments

1558710875284000046530_sktwi1f5rjvs16s0m.png get_app