Session timeout value for Automation Point's Notification Manager Website
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Session timeout value for Automation Point's Notification Manager Website

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Article ID: 46517

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Updated On:

Products

Automation Point

Issue/Introduction

The Notification Manager Website application sometimes times out after only a few minutes of inactivity in the browser.  The web.xml file for the Apache Tomcat 7 server session timeout value is set to 30 minutes.  What needs to be changed so that it can remain idle for a longer period of time without timing out?

Environment

Any Supported Microsoft Windows client or server operating system and Web Browser

Cause

The root cause of the issue is likely that the browser is losing session cookie information. This causes the browser to lose its link reference to the HTTP session object on the server, so whenever your application remains idle for too long, a new HTTP session object must be created which does not have any login information (so then it forces a new logon).

 

Resolution

To mitigate this issue block all cookies in your web browser. With cookies blocked in the web browser client, as per the design of the Notification Manager website application, the server will then pass the value of the HTTP session reference object as an HTTP request parameter by a technique called URL Rewriting. This way the link between the HTTP request, and the previously established HTTP session object, will remain preserved for up to 30 minutes of inactivity in your IE   browser session.  After a long period of inactivity, a new logon will no longer be needed.