Task persistence errors after upgrade
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Task persistence errors after upgrade

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Article ID: 46434

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

After upgrading Identity Manager, schema update errors appear in the application server log file:

"Task Persistence database schema was not upgraded successfully."

Environment

Release: CAIDMB99000-12.6.7-Identity Manager-B to B
Component:

Cause

This issue could be a symptom of the database upgrading script not completing correctly.

Resolution

Change directory to "C:\Program Files (x86)\CA\Identity Manager\IAM Suite\Identity Manager\tools\db\taskpersistence\"

Choose the folder with the version of your database (Oracle, MS SQL) and then run the script for upgrading from 12.5 version.

(idm_db_sqlserver_upgrade_125.sql or idm_db_oracle_upgrade_125.sql)