autoping to Agent fails with: Unexpected encryption type. AES received. DES expected.
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autoping to Agent fails with: Unexpected encryption type. AES received. DES expected.

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Article ID: 46186

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Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent

Issue/Introduction

After defining a new AutoSys Agent, the status of the Agent is stuck in "missing" and the 'autoping -m <hostname>' command fails. 

The Agent 'receiver.log' file shows the following error:

<Regular:2>.CybReceiverChannel.receive[:233] - cybermation.library.communications.CybConversationException: Unexpected encryption type. AES received. DES expected. 
at cybermation.library.communications.protocol.CybCommunicationProtocolRevisionTwo.receiveData(CybCommunicationProtocolRevisionTwo.java:509) 
at cybermation.library.communications.protocol.CybCommunicationProtocolRevisionTwo.receiveMessage(CybCommunicationProtocolRevisionTwo.java:315) 
at cybermation.library.communications.CybConversation.receiveMessage(CybConversation.java:429) 
at cybermation.commplugins.tcpip.receiver.CybReceiverChannel.receive(CybReceiverChannel.java:173) 
at cybermation.commplugins.tcpip.receiver.CybReceiverChannel.call(CybReceiverChannel.java:138) 
at cybermation.commplugins.tcpip.receiver.CybReceiverChannel.call(CybReceiverChannel.java:50) 
at cybermation.commplugins.tcpip.receiver.CybReceiverScheduler$CallableWrapper.call(CybReceiverScheduler$CallableWrapper.java:352) 

Environment

All supported releases

Cause

When an AutoSys Scheduler connects to an Agent, it passes an AES encryption key. This key must match the key in the Agent's own <agent_install_dir>/cryptket.txt file or the communication will be rejected.

If you are seeing this error in the receiver.log "Unexpected encryption type. AES received. DES expected.", it is because the Agent is using its default DES encryption key which does not match the default AES encryption key being sent by the Scheduler.

Resolution

You can simply copy over the $AUTOUSER/cryptkey.txt file from the Scheduler manager to the Agent, replacing its existing <agent_install_dir>/cryptkey.txt file.

Restart the Agent for the change to take effect.

Now the Agent's local cryptkey.txt matches the default AES encryption key that the AutoSys Scheduler is sending.