On 10/21/26 two critical Remote Code Execution (RCE) security vulnerabilities were discovered in PHP and both rated CVSSv4 (Common Vulnerability Scoring System) 9.2. If exploited, an unauthenticated attacker could potentially execute arbitrary code on the host system.
The Tanzu division initiated the incident response process immediately upon receiving the PHP advisory. Pipelines started releasing fixes within the hour and all Tanzu and TrueSource products were fully patched by the end of the day.
The core components of Tanzu Platform and Tanzu Data Intelligence are not affected by these vulnerabilities. For all customers running PHP workloads on platform all necessary patches have been released through the PHP buildpacks and can be easily rolled out for all applications via the cf restage command.
For customers leveraging TrueSource Trusted Artifacts or Bitnami Secure Images, all PHP related images were promptly patched.
Customers who have applied the patches are not vulnerable to the PHP RCE exploits. To ensure all environments are fully protected against these vulnerabilities, customers must update their deployments to the latest patched versions immediately.
The vulnerabilities:
Vulnerable PHP versions: All versions from 5.4 through 8.5.11
Patched in: PHP 8.5.12, 8.4.27, 8.3.36 and 8.2.35