USM reports an "unknown error has occurred" with UMP running on Rhel

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Article ID: 4577

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Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

 The customer did a fresh install of UIM and UMP on Rhel 6.5 servers, and without any load on the system the USM would continuously report the same error message, making the portlet unusable:

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An unknown error has occurred.  Refreshing your browser may resolve the issue. 

Details: 

com.firehunter.ump.exceptions.DataFactoryException : null 

Info: 

Method: getAlarms(Long: 1470407413000, Long: 0) 

Method: getAlarms(Long: 1470407413000, Long: 0, Boolean: true) 

Method: getAlarmsFromDb(Long: 1470407413000, Long: 0, Boolean: true) 

Method: getAlarmFiltersForAcl(String: Superuser) 

 

Stack Trace: 

(80) Session error, Unable to open a client session for <hubip>:48000: Connection timed out 

Caused by: java.net.ConnectException: Connection timed out 

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Newer versions of the USM portlet did not resolve the issue, and the USM tracing enabled on the portlet did not give any useful information about the problem.

Cause

This was caused by a known issue with  Linux 3.10.0-229.el7.x86_64. 

Environment

UIM and UMP 8.4 running on Rhel 6.5

Resolution

To ultimately resolve the issue, the customer had to upgrade to kernel version Linux 3.10.0-327.36.3.el7.x86_64. Once this was done the connection timeout errors were resolved without any further  intervention on the application side.