Alarms do not clear in Spectrum after closing Service Desk Manager tickets
search cancel

Alarms do not clear in Spectrum after closing Service Desk Manager tickets

book

Article ID: 45726

calendar_today

Updated On:

Products

Spectrum

Issue/Introduction

When closing a ticket in Service Desk Manager (SDM) the subsequent alarm in Spectrum OneClick (OC) does not clear.

Reviewing the oc-notification.log in the $NX_ROOT/bin directory on the SDM machine may contains errors:

"Unable to translate Service Desk notification OneClick command"

It may also contain connection errors:

Error occurred - unable to process notification.Caused by:java.net.ConnectException: Connection timed out: connect	at java.net.DualStackPlainSocketImpl.connect0(Native Method)	at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)	at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)	at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)	at java.net.AbstractPlainSocketImpl.connect(Unknown Source)	at java.net.PlainSocketImpl.connect(Unknown Source)	at java.net.SocksSocketImpl.connect(Unknown Source)	at java.net.Socket.connect(Unknown Source)	at java.net.Socket.connect(Unknown Source)	at sun.net.NetworkClient.doConnect(Unknown Source)	at sun.net.www.http.HttpClient.openServer(Unknown Source)	at sun.net.www.http.HttpClient.openServer(Unknown Source)	at sun.net.www.http.HttpClient.<init>(Unknown Source)	at sun.net.www.http.HttpClient.New(Unknown Source)	at sun.net.www.http.HttpClient.New(Unknown Source)	at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source)	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)	at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)	at OneClickNotification.sendRequest(OneClickNotification.java:288)	at OneClickNotification.main(OneClickNotification.java:74)

Environment

Release: Any
Component:

Cause

This can be caused by improper configuration of the SDM <-> OC Integration.

Resolution

  1. On the SDM machine, go into $NX_ROOT/bin
  2. Open oc-integration.cfg file
  3. Confirm all the OneClick settings in this file, especially the port.

The information in this file should be able to make a connection to the OneClick machine via HTTP.

server=OneClick Hostname

port=OC Port

path=spectrum

user=Administrator

password=

All fields can be updated in this file besides the password.  If the password needs to be updated, please run the OneClickIntegrationSetup executable again.