During an upgrade pre-check, the DNS resolution of the Fleet FQDN will fail.
Within Ops Lifecycle, the following error is presented in the UI for the task:
Failed Stages: download_bundle_file, stage_bundle_file; ops.task.stage.failed
The sddc-upgrade-service will report an error similar to the following:
Unexpected error: I/0 error on GET.request for \"https://<FLEET-FQDN>/depot-service/content-gateway/PROD/COMP/VROPS/VMware_Cloud_Foundation_Operations-9.1.1.0.25679887-upgrade-manifest. json\": <FLEET-FQDN> : Temporary failure in name resolution"
VCF 9.1
Identify the primary Ops node:
https://<IP_or_FQDN>/admin.To enable SSH on the node:
https://<IP_or_FQDN>/admin. Edit the "/etc/hosts' file using vi add an additional entry for the Fleet FQDN.
Re-attempt the upgrade precheck.