"DB90152E - DATACOM PARM SYNTAX ERROR (A)" at CAIRIM start
search cancel

"DB90152E - DATACOM PARM SYNTAX ERROR (A)" at CAIRIM start

book

Article ID: 45634

calendar_today

Updated On:

Products

Datacom DATACOM - AD CIS COMMON SERVICES FOR Z/OS 90S SERVICES Common Services Datacom/DB

Issue/Introduction

When running the CAIRIM (CAS9) process for CA Datacom version 15.0, the process for the control statements ends with an INIT error and RC=0008, and displays a message about SYNTAX ERROR(A):

CAS9115I - Input: PRODUCT(CADATACOM) VERSION(BD15) INIT(DBCR5PR) LOADLIB(...)
DB90150I - DATACOM DBCR5PR  2015/12/31-1146 15.1                               
DB90152E - DATACOM PARM SYNTAX ERROR (A)                                        
DB90153E - DATACOM INITIALIZATION FAILED                                       
CAS9140E - Init error: CADATACOM            Ver BD15, Init routine RC=0008     

Environment

This applies to CA Datacom/AD and CA Datacom/DB at version 15.x.

Cause

In version 15.0, the process of initialization was simplified. Version 14.x loaded two programs - DBPCCPR and DBPCSPR, and in version 15.x, the functionality was rolled into one program - DBPCCPR.

Resolution

The SYNTAX ERROR (A) is typically caused by not having the correct control statement, and may be the result of deleting the wrong set from a previous version 14.x configuration, or from having an error in the PARM field.

Be sure that you are referencing the PCC module as shown here:

PRODUCT(CA DATACOM) VERSION(BD15) INIT(DBCR5PR)  -
LOADLIB(…your CA Datacom CABDLOAD or CAAXLOAD…)  -
PARM(PC=PROD,PCC=DBPCCPR)

As always, please contact CA Technologies support for CA Datacom if you have further questions.