CA Business Intelligence Jaspersoft Reports Server License Expired after installation
search cancel

CA Business Intelligence Jaspersoft Reports Server License Expired after installation

book

Article ID: 45578

calendar_today

Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

 

After successful installation an error as mentioned below about the license is received when attempting to access the JasperServer URL.

 

"License Failed

 

Your license has expired. 

If you evaluated JasperReports Server and have just installed a new version of it, your evaluation license has expired.

Please contact [email protected] for assistance."

 

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License

Component:


Windows 2012 / Windows 2008

Service Desk Manager 14.1.03 and up 
CABI 6.2 and up (JasperReports Server)

Cause

The jasperserver.license file is not referenced with an entry in the java parameters for Tomcat.

Resolution

1. Go to the Jasper Reports Server

2. Go into the Tomcat Installation bin directory (I.e. C:\Tomcat8\bin)

3. Execute Tomcat8w.exe

4. Add the license parameter to the Java tab as shown below:

-Djs.license.directory=<tomcat_home>/webapps/jasperserver-pro

5. Click Apply and OK

6. Restart Apache Tomcat for Jaspersoft

Additional Information

If the above license setting is valid, you may also need to delete the work directory under the Tomcat install directory location

License configuration for Jasper soft server 7.2  : https://knowledge.broadcom.com/external/article?articleId=209614