New CABI component is not working on new install
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New CABI component is not working on new install

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Article ID: 4551

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

When accessing the URL for the CABI server, you receive a 404 error. In the cabi logs you see the following:

Oct 19 09:21:58:522 [UserSynchronizationThread, cabi] JasperUserUtility:login(): URL attempted :http://192.0.2.1/cabijs/login.html
Oct 19 09:21:58:522 [UserSynchronizationThread, cabi] JasperUserUtility:login(): Response code :404
Oct 19 09:21:58:522 [UserSynchronizationThread, cabi] UimToJasperUserSync():

You can't log into CABI. You've tried all the known passwords.

Environment

  • Windows
  • Microsoft SQL Server
  • Bundled cabi 3.00

Cause

The superuser password was changed or is corrupted.

Resolution

  1. Delete the cabi probe and wasp in Admin Console 2 from the robot on which cabi is installed.
  2. On the filesystem of the cabi robot delete the following:
    • <nimsoft home>\cabi
    • <nimsoft home>\probes\service\cabi
    • <nimsoft home>\probes\service\wasp
  3. On the UIM database, drop all the tables that CABI puts down to start fresh (sql script attached)
  4. Reinstall CABI.

Additional Information

drop_cabi_tables.sql is attached to this article.

Attachments

1640720201306__drop_cabi_tables.sql get_app